经典编辑器

描述

经典编辑器是WordPress团队维护的官方插件,用于恢复以前的(“经典”)WordPres编辑器和“编辑帖子”屏幕。它可以使用插件来扩展屏幕、添加旧式元框或依赖于以前的编辑器。

Classic Editor是一个官方的WordPress插件,将在2024年之前得到完全支持和维护,或根据需要进行维护。

乍一看,此插件添加了以下内容:

  • 管理员可以为所有用户选择默认编辑器。
  • 管理员可以允许用户更改其默认编辑器。
  • 如果允许,用户可以为每个帖子选择使用哪个编辑器。
  • 每个帖子都会在上次使用的编辑器中打开,而不管上次是谁编辑的。这对于在编辑内容时保持一致的体验非常重要。

此外,Classic Editor插件包括几个过滤器,允许其他插件控制设置,以及每个帖子和每个帖子类型的编辑器选择。

默认情况下,此插件隐藏了新块编辑器(“Gutenberg”)中可用的所有功能。

屏幕截图

  • 设置->写入屏幕上的管理员设置。
  • 配置文件屏幕上的用户设置。当允许用户切换编辑器时可见。
  • “Action links”可选择其他编辑器。当允许用户切换编辑器时可见。
  • 链接以在经典编辑器中编辑文章时切换到块编辑器。当允许用户切换编辑器时可见。
  • 链接以在块编辑器中编辑文章时切换到经典编辑器。当允许用户切换编辑器时可见。
  • Network settings可选择网络的默认编辑器,并允许站点管理员进行更改。
  • “切换到经典编辑器”链接。

常见问题解答

默认设置

当激活和使用经典(非块)主题时,此插件将恢复以前的(“经典”)WordPress编辑器并隐藏新的块编辑器(“Gutenberg”)。
这些设置可以在设置=>写入屏幕上更改。

网络安装的默认设置

有两个选项:

  • 当网络激活和使用经典(非块)主题时,此插件将经典编辑器设置为默认,并阻止站点管理员和用户更改编辑器。
    可以更改设置,并可以在“网络设置”屏幕上选择默认的网络范围编辑器。
  • 未激活网络时,每个站点管理员都可以激活插件并为其用户选择选项。

它在主块编辑器菜单中,请参见截图

这是否适用于完整的网站编辑和区块主题?

不,因为块主题依赖于块。请参阅阻止主题文章了解更多信息。

评论

2024年2月3日
谢谢你!!!这让我的生活更轻松!
2023年12月29日
哇,我必须在LOL的Block Editor中写一篇评论。经典编辑器是我使用过的最好的插件。在安装任何其他插件之前,我总是先安装这个插件。WordPress请删除块内容并将其设为默认值。
阅读所有1155条评论

贡献者和开发人员

“经典编辑器”已被翻译成71种语言环境。谢谢你翻译人员感谢他们的贡献。

将“经典编辑器”翻译成您的语言。

对开发感兴趣?

浏览代码,查看SVN存储库,或订阅开发日志通过RSS公司

变更日志

1.6.3

  • 添加了一些WPCS修复,支持GitHub上的NicktheGeek。
  • 在自述文件中更新了“Tested up to”,并将其从classic-editor.php中删除。这将在将来修复安全插件中的误报错误。

1.6.2

  • 修复了阻止保存上次使用的编辑器的错误。

1.6.1条

  • 修复了基于块编辑器的小部件屏幕上的警告。
  • 修复了不推荐使用的筛选器。

1.6

  • 为WordPress 5.5更新。
  • 修复了调用不推荐使用的函数、不必要地注册卸载挂钩以及一些字符串的大小写等小问题。

1.5

  • 为WordPress 5.2和Gutenberg 5.3更新。
  • 增强并修复了“上次编辑时打开的帖子”逻辑。
  • 修正了添加post状态,以便可以从其他插件轻松访问。

1.4

  • 在网络上安装时,取消了仅网络激活的限制。
  • 增加了对网络管理员选择默认网络范围编辑器的支持。
  • 修复了网络“关于”屏幕上的警告中的设置链接。
  • 将“切换到经典编辑器”菜单项正确添加到块编辑器菜单中。

1.3

  • 修复了删除“Try Gutenberg”仪表板小部件的问题。
  • 修复了在“新增功能”屏幕上显示升级后通知的条件。选择经典编辑器且用户无法切换编辑器时显示。

1.2

  • 修正了在保存草稿文章之前从“添加新文章”屏幕切换编辑器的问题。
  • 修复了将编辑URL附加到经典编辑器查询变量。
  • 将WordPress 5.0的检测更改为不使用版本检查。修复了测试5.1-alpha时的错误。
  • 更改了选项的默认值,允许用户将编辑器切换为false。
  • 增加了Gutenberg插件的禁用功能,并将所需的WordPress版本降低到4.9。
  • 补充类编辑器网络默认设置过滤器。

1.1

修复了一个错误,在允许用户切换编辑器时,它可能会尝试为不支持编辑器的帖子类型加载块编辑器。

1

  • 为WordPress 5.0更新。
  • 将所有“古腾堡”名称/引用更改为“块编辑器”。
  • 刷新了设置UI。
  • 删除了Gutenberg插件的禁用。这是为了在WordPress 4.9中进行测试而添加的。想要继续在WordPress 5.0及更高版本中使用Gutenberg开发的用户不需要另一个插件来禁用它。
  • 添加了对默认编辑器的per-user设置的支持。
  • 添加了对管理员的支持,以设置站点的默认编辑器。
  • 添加了对管理员的支持,允许用户更改其默认编辑器。
  • 添加了对网络管理员的支持,以防止站点管理员更改默认设置。
  • 添加了存储每个帖子最后使用的编辑器并在下次打开的支持。当用户可以选择默认编辑器时启用。
  • 在帖子屏幕上的帖子列表中添加了“帖子编辑器状态”。显示将为文章打开的编辑器。当用户可以选择默认编辑器时启用。
  • 补充classic_editor启用的editors用于postclassic_editor启用的editors用于post_type过滤器。其他插件可以使用它来控制或覆盖用于特定帖子类型的编辑器。
  • 补充类编辑器插件设置过滤器。其他插件可以使用它来覆盖设置并禁用设置UI。

0.5

  • 为古腾堡4.1和WordPress 5.0-beta1更新。
  • 删除了古腾堡现有的一些功能。
  • 修复了在查看文章修订后重定向回经典编辑器的问题。

0.4

  • 修复了在古腾堡插件未激活时删除“Try Gutenberg”标注的问题。
  • 修正为总是在插件列表中显示设置和设置链接。
  • 更新了自述文本。

0.3

  • 将选项从复选框更新为两个单选按钮,看起来更清晰。感谢@designsimply为标签文本提供建议。
  • 一些常规更新和清理。

0.2

  • 更新Gutenberg 1.9。
  • 当Gutenberg未激活时,删除警告和自动停用。

0.1

首次发布。