Error when compiling PHP version, oh, by the way, there may be differences below php7, pure system
I haven't published any papers for a long time. I don't want to organize the documents very much[____ ]

 #Basically, the basic compiler parameters are the full installation of all the built-in parameters. The basic ones are the full installation of all the built-in parameters. The basic ones are the self-contained full installation file file file = / opt / temp / cache / cache / config. Cache. Cache '' -- prefix = / opt / temp / PHP / php-7.2.6 / etc '' -- with-config-file-scan-dir = / opt / temp / PHP / php-7.2.6 / PHP / php-7.2.6/var / db '' -- Disable all '' '-- enable short-short-tags'' '-- enable short-short-tags' ", 2.6/var / db' '-- Disable all' '"' -- enable short-short-tags' '"'" -- enable short-short-tags' "'" -- enable short-tags' -- tags' -- tags' -- enable opcache '' -- enable DBA '' -- enable-ipv6 ' '--enable-calendar' '--enable-wddx' '--enable-static' '--enable-inifile' '--enable-inline-optimization' '--enable-cli' '--enable-ftp' '--enable-filter' '--enable-gcov' '--enable-maintainer-zts' '--enable-json' '--enable-hash' '--enable-exif' '--enable-mbstring' '--enable-mbregex' '--enable-libgcc' '--enable-pdo' '--enable-posix' '--enable-embed'  '--enable-sockets' '--enable-debug' '--enable-phpdbg' '--enable-zip' '--enable-bcmath' '--enable-fileinfo' '--enable-ctype' '--enable-cgi' '--enable-soap' '--enable-pcntl' '--enable-phar' '--enable-session' '--enable-tokenizer' '--with-imap-ssl' '--with-ldap' '--with-tidy' '--with-kerberos' '--with-xmlrpc' '--enable-fpm' '--enable-dtrace'  '--with-pcre-regex' '--with-pcre-dir=/usr' '--with-mhash' '--with-mcrypt=/usr' '--with-zlib=/usr' '--with-curl=/usr' '--with-readline=/usr' '--with-libedit=/usr/local' '--with-gd=shared' '--enable-gd-native-ttf' '--with-png-dir=/usr' '--enable-intl' '--with-openssl=/usr' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd' '--with-sqlite3'  '--with-pdo-sqlite' '--with-pgsql=/usr/bin' '--with-pdo-pgsql=/usr/bin' '--enable-dom' '--enable-libxml' '--enable-simplexml' '--enable-xml' '--enable-xmlreader' '--enable-xmlwriter' '--with-xsl' '--with-libxml-dir=/usr' '--with-gettext=/usr' '--with-iconv' '--with-bz2=/usr' '--enable-shmop' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg'  '--with-gmp=/usr' '--with-pear=/opt/temp/php/php-7.2.6/lib/php/pear' '--with-libdir=lib64' '--with-mcrypt=/usr/lib64' '--with-readline'

Error: configure: error: Please reinstall the libcurl distribution – easy.h should be in/include/curl/
resolvent: yum install -y curl-devel

Error: configure: error: jpeglib.h not found.
resolvent: yum install -y libjpeg-devel

Error: configure: error: png.h not found.
resolvent: yum install -y libpng-devel

Error: configure: error: To enable code coverage reporting you must have LTP installe
resolvent: yum install -y lcov

Error: configure: error: Cannot find sys/sdt.h which is required for DTrace support
resolvent: yum install -y systemtap-sdt-devel , apt install -y systemtap-sdt-dev

Error: configure: error: Cannot find OpenSSL's libraries
resolvent: yum install openssl openssl-devel openssl-libs
Note: 64 bit system is added at compile time --with-libdir=/usr/lib64 Or put /usr/lib64/libssl.so Copy to /usr/lib/libssl.so

Error: configure: error: Unable to locate gmp.h
resolvent: yum install -y gmp gmp-devel

Error: configure: error: Unable to detect ICU prefix or no failed. Please verify ICU install prefix and make sure icu-config works.
resolvent: yum install -y icu libicu libicu-devel

Error: configure: error: Please reinstall libedit - I cannot find readline.h
resolvent: yum install -y readline readline-devel
Note: 64 bit system is added at compile time --with-readline You may also need to download and compile the latest version of libedit

Error: configure: error: Cannot find libtidy
resolvent: yum install -y readline readline-devel , apt install libtidy-dev libtidy5

Error: configure: error: Cannot find OpenSSL's <evp.h>
resolvent: yum install -y openssl openssl-devel libssl-dev

Error: configure: error: Please reinstall the BZip2 distribution
resolvent: yum install -y bzip2 bzip2-devel , apt install libbz2-dev

Error: configure: error: Please reinstall the libcurl distribution
resolvent: yum install -y curl-devel , apt install libcurl4-gnutls-dev

Error: configure: error: mcrypt.h not found.
resolvent: apt install libmcrypt4-dev libmcrypt-dev

Error: configure: error: Cannot find libpq-fe.h.
resolvent: apt install libpq-dev

Error: configure: error: Please reinstall readline - I cannot find readline.h
resolvent: apt install libreadline-dev

Error: configure: error: xslt-config not found.
resolvent: apt install libxslt1-dev

Error: configure: error: cURL version 7.10.5 or later is required to compile php with cURL support
resolvent: apt install libcurl4-openssl-dev , apt install libcurl4-gnutls-dev

Error: configure: error: xslt-config not found. Please reinstall the libxslt >= 1.1.0 distribution
resolvent: apt install libxslt1-dev , yum install -y libxslt-devel Maybe the devel version will not be greater than 1.1.0 Official website Compile and install

Error: configure: error: Unable to locate gmp.h
resolvent: apt install libgmp-dev

Error: configure: error: utf8_ mime2text() has new signature, but U8T_ CANONICAL is missing. This should not happen. Check config.log for additional information.
resolvent: apt install libc-client2007e-dev , apt install libc-client-dev

Error: configure: error: This c-client library is built with Kerberos support.
resolvent: apt install libkrb5-dev , consider adding --with-kerberos and --with-imap-ssl parameter

Error: configure: error: libfbclient, libgds or libib_ util not found! Check config.log for more information.
resolvent: apt install firebird-dev It could be apt install firebird2-dev

Error: configure: error: Cannot find ldap.h
resolvent: apt install libldap2-dev

Error: configure: error: Please reinstall the libzip distribution
resolvent: apt install libzip-dev

Error: configure: error: Package requirements (libzip >= 0.11) were not met: No package 'libzip' found
resolvent: yum install -y libzip-devel zip Maybe the devel version will not be greater than 0.11. You need to go by yourself Official website Compile and install

Error: configure: error: Package requirements (libxml-2.0 >= 2.7.6) were not met: No package 'libxml-2.0' found
resolvent: yum install -y libxml2-devel Maybe the devel version will not be greater than 2.7.6. You need to go by yourself Official website Compile and install

Error: configure: error: Package requirements (libcurl >= 7.15.5) were not met: No package 'libcurl' found
resolvent: yum install -y libcurl-devel Maybe the devel version will not be greater than 7.15.5 Official website Compile and install

Error: configure: error: Package requirements (oniguruma) were not met: No package 'oniguruma' found
resolvent: yum install -y oniguruma-devel oniguruma

label: php , compile , configure

Add a new comment