June 2018

There is no problem in setting up agents in general settings, but today we have to operate websockt.

 Server {
location / {
proxy_ Pass Http://127.0.0.1 : 10086; 
proxy_ Set_ Header Host $host; 
proxy_ Set_ Header X-Real-IP $remote_ Addr; 
proxy_ Set_ Header X-Forwarded-For $proxy_ Add_ X_ Forwarded_ For; 
proxy_ Set_ Header REMOTE-HOST $remote_ Addr; 
proxy_ Http_ Version 1.1; 
proxy_ Read_ Timeout 300s;}}

Nginx -t Once

The following errors will occur:
Nginx: [emerg] unknown "connection_ Upgrade "variable

This is where there is a pit.

It involves a design problem of nginx. End-to-end and Hop-by-hop Headers
I am still talking about it here, so as not to mislead my children.

Map sets up mapping tables for one or more variables in nginx.

Here are a few configurations to add:

 Http {
map $http_ Upgrade $connection_ Upgrade {
default upgrade; close '; 
}

server {
location / { 
proxy_ Set_ Header Upgrade $http_ Upgrade; 
proxy_ Set_ Header Connection $connection_ Upgrade;

It looks like the finance of Lian Bi is going to fall. More than 1000 of the K3 cars on last year did not come out.

I hope not to sell more than 700 million for 618, and run away with my sister-in-law.

2018.06.26 150 is still in cash. It's not very hopeful.
2018.07.20 APP can also open...

Error in compiling PHP version, oh, incidentally, there may be discrepancy in php7 below, pure system.
For a long time, there is no written word. The document does not want to tidy up (3[____ ]

 The compilation parameters are basically 
'./configure''--cache-file=/opt/temp/cache/. Config.cache ''--prefix=/opt/temp/php/php-7.2.6''--with-config-file-path=/opt/temp/php/php-7.2.6/etc''--with-config-file-scan-dir=/opt/temp/php/php-7.2.6/var/db''--disable-all''--enable-short-tags''--enable-opcache''--enable-dba''--enable-ipv6' '--enable-calendar''--enable-wddx''--enable-static''--enable-inifile''--enable-inline-optimization''--enable-cli''--enable-ftp''--enable-filter''--enable-gcov''--enable-maintainer-zts''--enable-json''--enable-maintainer-zts' '--enable-sockets''--enable-debug''--enable-phpdbg''--enable-zip''--enable-bcmath''--enable-fileinfo''--enable-ctype''--enable-cgi''--enable-soap''--enable-pcntl''--enable-phar''--enable-pcntl' '--with-pcre-regex''--with-pcre-dir=/usr''--with-mhash''--with-mcrypt=/usr''--with-zlib=/usr''--with-curl=/usr''--with-readline=/usr''--with-libedit=/usr/local''--with-gd=shared''--enable-gd-native-ttf''--with-png-dir=/usr''--enable-gd-native-ttf' '--with-pdo-sqlite''--with-pgsql=/usr/bin''--with-pdo-pgsql=/usr/bin''--enable-dom''--enable-libxml''--enable-simplexml''--enable-xml''--enable-xmlreader''--enable-xmlwriter''--with-xsl''--with-libxml-dir=/usr''--with-xsl' '--with-gmp=/usr''--with-pear=/opt/temp/php/php-7.2.6/lib/php/pear''--with-libdir=lib64''--with-mcrypt=/usr/lib64''--with-readline'

Error: Configure: error: Please reinstall the libcurl distribution easy.h should be in/include/curl/
Resolvent: Yum install -y curl-devel

Error: Configure: error: jpeglib.h not found.
Resolvent: Yum install -y libjpeg-devel

Error: Configure: error: png.h not found.
Resolvent: Yum install -y libpng-devel

Error: Configure: error: To enable code coverage reporting you must have LTP have
Resolvent: Yum install -y lcov

Error: Configure: error: Cannot find sys/sdt.h which is required for DTrace support
Resolvent: Yum install -y systemtap-sdt-devel , Apt install -y systemtap-sdt-dev

Error: Configure: error: Cannot find OpenSSL's Libraries
Resolvent: Yum install OpenSSL openssl-devel openssl-libs
Note: the 64 bit system is added at compile time. --with-libdir=/usr/lib64 Or put /usr/lib64/ Libssl.so Copy to /usr/lib/ Libssl.so

Error: Configure: error: Unable to locate gmp.h
Resolvent: Yum install -y GMP gmp-devel

Error: Configure: error: Unable to detect ICU prefix or no failed. Please failed.
Resolvent: Yum install -y ICU libicu libicu-devel

Error: Configure: error: Please reinstall libedit I cannot find readline.h
Resolvent: Yum install -y readLine readline-devel
Note: the 64 bit system is added at compile time. --with-readline You may also need to download and compile the latest version separately. Libedit

Error: Configure: error: Cannot find libtidy
Resolvent: Yum install -y readLine readline-devel , Apt install libtidy-dev libtidy5

Error: Configure: error: Cannot find OpenSSL's <evp.h>
Resolvent: Yum install -y OpenSSL openssl-devel libssl-dev

Error: Configure: error: Please reinstall the BZip2 distribution
Resolvent: Yum install -y bzip2 bzip2-devel , Apt install libbz2-dev

Error: Configure: error: Please reinstall the libcurl distribution
Resolvent: Yum install -y curl-devel , Apt install libcurl4-gnutls-dev

Error: Configure: error: mcrypt.h not found.
Resolvent: Apt install libmcrypt4-dev libmcrypt-dev

Error: Configure: error: Cannot find libpq-fe.h.
Resolvent: Apt install libpq-dev

Error: Configure: error: Please reinstall readLine I cannot find readline.h
Resolvent: Apt install libreadline-dev

Error: Configure: error: xslt-config not found.
Resolvent: Apt install libxslt1-dev

Error: Configure: error: cURL version 7.10.5 or later is required to compile to
Resolvent: Apt install libcurl4-openssl-dev , Apt install libcurl4-gnutls-dev

Error: Configure: error: xslt-config not found. Please reinstall the libxslt > = 1.1.0 distribution
Resolvent: Apt install libxslt1-dev , Yum install -y libxslt-devel Maybe the devel version will not be larger than 1.1.0. Official website Compilation and installation

Error: Configure: error: Unable to locate gmp.h
Resolvent: Apt install libgmp-dev

Error: Configure: error: utf8_ Mime2text () has new signature, but U8T_ CANONICAL is missing. This should not happen. Check Config.log For additional information.
Resolvent: Apt install libc-client2007e-dev , Apt install libc-client-dev

Error: Configure: error: This c-client library is built with Kerberos support.
Resolvent: Apt install libkrb5-dev Consider adding --with-kerberos and --with-imap-ssl parameter

Error: Configure: error: libfbclient, libgds or libib_ Util not found! Check Config.log For more information.
Resolvent: Apt install firebird-dev It might be Apt install firebird2-dev

Error: Configure: error: Cannot find ldap.h
Resolvent: Apt install libldap2-dev

Error: Configure: error: Please reinstall the libzip distribution
Resolvent: Apt install libzip-dev

Error: Configure: error: Package requirements (libzip > > 0.11) were not met: No package'libzip'package
Resolvent: Yum install -y libzip-devel zip Maybe the devel version will not exceed 0.11. Official website Compilation and installation

Error: Configure: error: Package requirements (libxml-2.0 > > 2.7.6) were not met: No package No
Resolvent: Yum install -y libxml2-devel Maybe the devel version will not be larger than 2.7.6. Official website Compilation and installation

Error: Configure: error: Package requirements (libcurl > > 7.15.5) were not met: No package No
Resolvent: Yum install -y libcurl-devel Maybe the devel version will not be larger than 7.15.5. Official website Compilation and installation

Error: Configure: error: Package requirements (oniguruma) were not met: No package'oniguruma'package
Resolvent: Yum install -y oniguruma-devel oniguruma