媒体维基1.21

来自MyaWiki.Org
跳转到导航 跳到搜索

媒体维基1.21是一个过时的版本MeaWiki,它是在2012年9月和2013年3月之间开发的。它是通过增量的“WMF”在维基媒体基金会Wiki上部署的。从2012年10月到2013年3月。这是对用户感兴趣的主要变化的总结。版本说明文件的完整列表的变化。最终版本发布于5月25日2013。下载 获得副本。

有什么新鲜事吗?[编辑]

MiTaWiKi 1.21包括在较小的双周“1.21WMF”中发布的所有更改。X软件部署到维基媒体网站。

关于候选发行人的评论[编辑]

WikECHE-L邮件列表

  • 布吉拉:46934
    我只想提一个问题:在我的数据库(MySQL)中,预先升级的作业有JojyRead随机设置为0,似乎没有被拾取——甚至当我使用选项-type = RePrEtEXTE时也没有。我可以重复替换文本操作,所以这对我来说不是大问题。但是,如果这是升级的正常行为,也许它应该在注释中提到。

更清晰的电子邮件通知[编辑]

错误14901 -电子邮件通知错误日志行动为新的页面创建第三个最公开的MyIaWiKi漏洞已经修复。因此,通知现在清楚地表明在被监视的页面上执行了什么操作,以防它们被创建、删除、恢复、移动或更改。

仍有一些已知问题. 如果你定制美中不足的身体在您的wiki上,您必须删除或更新它;参见完整文档.

[编辑]

CoNeNBLY皮肤已被重新构造,使其再次相关,更兼容现有脚本,更类似于结构,以矢量和单本,重用大量现有代码。

对于最终用户来说,唯一的主要区别应该是侧栏菜单的轻微重新排序(“上下文”子菜单被删除,其内容合并为其他菜单”。然而,如果你依赖于它所使用的HTML,你需要重新审视你的工具。

接线员 [编辑]

作为其中的一部分维基达倡议,1.21采用可扩展框架(“接线员“”页面可以包含WiKiTeXT以外的东西。

目前,内置内容类型仅限于

  • WiKiTeX-WiKiTeXe,像往常一样
  • JavaScript -用户提供的JavaScript代码
  • CSS -用户提供的CSS代码
  • 文本-纯文本

扩展开发人员可以创建附加的内容类型。扩展:事件日志使用CordStand实现JSON模式的命名空间,可以作为参考。其他扩展,如抄写本也要利用新的功能。

CraceDANDELL影响DIFF渲染,处理CSS和JavaScript页面,导入/导出和API。

支持高DPI显示器[编辑]

MiTaWiKi现在尝试向苹果等高像素密度屏幕提供更高分辨率的图像。视网膜屏幕(见GRITIT改变24115详情请参阅。这是一项正在进行中的工作,所以正常分辨率图像可能仍然出现在某些地方和一些浏览器版本中。管理员可能需要注意他们的图像缩放软件的高负载。

AJAX巡逻[编辑]

  • 错误7851用户等待最长的特性:一次点击阿贾克斯 巡逻. 有了这个新的特性,用户可以将修改或页面标记为“点击”,同时停留在当前页面上。

国际化[编辑]

  • 虫24156最后对通用测井框架进行了完全定位。然而,对于每个动作(无论是在核心还是扩展)中的日志记录仍可能需要更新以使用新系统。
  • 虫40367MiTaWiki:贡献现在反映了用户的性别。

新帐户[编辑]

  • 虫22457现在通过电子邮件发送临时密码更容易为其他用户创建帐户:特殊:CreateAccount现在显示登录用户的复选框来使用此功能,而不是按钮。
  • 帐户API:BOTS和其他脚本现在可以使用API创建用户帐户,而不是试图伪提交HTML表单。

创建帐户欢迎[编辑]

这个MealaWiki:欢迎加入消息被分割成MelaWiKi:欢迎用户MealaWiki:WelCOCOREST MSG因此,用户在创建账户时不再看到“登录成功”(虫42215如果自定义前一个消息并希望保存自定义,则必须相应地修改新消息。

现在在JavaScript消息中支持更多的WiKiTeXT[编辑]

jQuyMysg解析器现在支持WikLink和国际标准化组织:截断。有关详细信息,请参见手册:消息API.

使用导航标题的语义标题[编辑]

以前的使用方案(每个皮肤变化)

和/或
标签(除了在层次结构中除了主H1>上面没有什么之外)改变了在整个导航中始终使用

S作为所有皮肤中的portlet标题。

对于普通浏览器来说,

是隐藏的,但对于屏幕阅读器或文本浏览器来说是可以访问的。

虽然这种改变是次要的,但它可能需要在任何定制的CSS或JS(或在屏幕刮板中)进行类似的小更新。


扩展校对支持[编辑]

基于UCA的基于Latin、希腊和西里尔字母的68种语言的分类排序现在得到了支持。您可以通过设置来使用它们。$WGCype排序规则= UCA-<朗格>在哪里<兰码>是适当的语言代码。

捆绑扩展[编辑]

新捆绑1.21错误43815):

也见[编辑]