手册:UpDATE.PHP

来自MyaWiki.Org
跳转到导航 跳到搜索
此页为译本页面的手册:UpDATE.PHP翻译完成21%。

拆卸器

UpDATE.PHP检查是否MIDAWIKI数据库模式需要更新,以便与MyaWiKi的当前版本一起工作。你应该跑步UpDATE.PHP后各升級在MadiaWiKi或更新或安装需要架构更新的扩展之后。大多数需要模式更新的扩展在它们的文档中都会这样说。

纳维加多

如果无法访问服务器的命令行,则使用网络更新器运行更新脚本。

渐次网络更新器

科曼多斯岛

从命令行,或SSH shell或类似:

  • 改为维护目录
  • 运行更新脚本:
$PHP UpDATE.PHP
广告语 Advertencia: UpDATE.PHP可能会退出错误,使数据库处于不一致的状态。总是备份运行脚本之前的数据库!
此维护脚本可以通过$WalgOrgStudioPaseDimes (1.18.0)$WGMISM模式 拥有极其繁忙的Wiki的人可能需要小心地进行升级,但是如果你不确定这是否适用于你,那么它可能不会。
使用以下内容流浪者 实例(来自你的流浪者SSH)。
$MWScript UpDATE.PHP

帕拉地铁

该脚本提供了一些Wiki环境中可能需要的几个参数(泛型、脚本依赖和脚本特定)。

通用维护参数
帮助
用于获取所有可用脚本参数(泛型、脚本依赖和脚本特定)的提示,以及对它们的用法的简短解释。这些是较少使用的参数。
脚本特定参数
--快
跳过倒计时序列
——诺普
不要清除ObjistCask表。正常地UpDATE.PHP净化对象缓存 表(通常包含解析器缓存和消息缓存),MSGI资源 MSGI资源链 (这些是用于资源加载器 数据库中的表中的消息缓存,并在1.21和以后的表中清除,如果不想清除此表,请使用——诺普选项
--多斯哈德
更新共享表也。
--力
即使脚本被配置选项禁用,也可以运行此脚本。
——康夫
指定配置文件(特定Wiki的LoalStalpIs.PHP文件)。用于维基家族.
--跳过复查
跳过兼容性检查
--跳过外部依赖关系
当使用Cyror .Loal.JSON让作曲家安装扩展和它们的依赖关系时,您可能会看到一个错误消息,称安装和所需版本之间存在不匹配(例如“MyaWiki/语义面包屑链接:1.3.0安装,1.3需要”)。您可以使用此参数忽略消息并运行UpDATE.PHP。
广告语 Advertencia: 只建议开发者使用。

扩展可以使用它们的模式来安装/更新它们的模式数据透视图 挂钩

Veasas-TabBieN